Admin not able to create index in dev tool


(Ajit) #1

Hi,
We have successfully installed readonly rest for both ES and kibana. I am trying to create index using admin login in dev tool. But I am getting below error.
{
“error”: {
“root_cause”: [
{
“reason”: “forbidden”
}
],
“reason”: “forbidden”
},
“status”: 403
}

I am creating index using below code
POST myindex/mytype/1
{
“Name”: “ajit”,
“LastName”: “Bhosale”
}

And my configuration for admin user is below.

  • name: "::ADMIN::"
    auth_key: admin:adminpass
    # KIBANA ADMIN ACCESS NEEDED TO EDIT SECURITY SETTINGS IN ROR KIBANA APP!
    kibana_access: admin

(Simone Scarduzio) #2

Hi @ajit,
this is expected. The kibana role Admin does not mean the user is in “god mode” and can do anything in to Elasticsearch (i.e. creating indices).

For more info, please refer to this chapter about kibana_access rule.


(Ajit) #3

Hi,
Not able to create index. Please guide us.


(Simone Scarduzio) #4

Does your admin user need to do anything and everything without restrictions?
In that case, just drop the kibana_access rule all together from the ACL block.