Cant see ROR Panel


(Cronin) #1

Hey Simone,
I’m not sure whats happening but in addition to the other issues I am having I now can’t even see the ROR panel in the admin:

Any feedback here?


(Simone Scarduzio) #2

Any logs? Version? Chrome js console errors?


(Cronin) #3

Using version 6.5.1

No Console Errors:

Looking in error logs I see the following error I don’t think the two are related:

{“type”:“log”,"@timestamp":“2018-12-11T05:00:00Z”,“tags”:[“error”,“readonlyrest_kbn”],“pid”:23455,“message”:“got an error [400] Bad Request for path /api/telemetry/v1/optIn”}

{“type”:“error”,"@timestamp":“2018-12-11T12:36:15Z”,“tags”:[“error”,“readonlyrest_kbn”],“pid”:23455,“level”:“error”,“error”:{“message”:“mapping set to strict, dynamic introduction of [telemetry] ynamic introduction of [telemetry] within [doc] is not allowed: [strict_dynamic_mapping_exception] mapping set to strict, dynamic introduction of [telemetry] within [doc] is not allowed”}


(Simone Scarduzio) #4

I think this is related to the bundling bug, will release a new version for 6.5.3 and let’s check again


(Cronin) #5

I figured it out! looks like using this plugin:

Was causing that panel not to show up for some reason. I turned it off for now. but if you have any idea how to fix it that would be great! must be some kind of collision.


(Simone Scarduzio) #6

Wow interesting, does this collide even after upgrading to 6.5.3?

BTW Datasweet is an important OSS contributor to ReadonlyREST Elasticsearch plugin :slight_smile:


(Cronin) #7

Yep Still happens as soon as I remove the plugin I can see the panel again in 6.5.3.

bit of a bummer because it’s a really great plugin.


(Simone Scarduzio) #8

In previous Kibana version the two plugins worked together correctly though, right?


(Barry Kaplan) #9

Nice to hear datasweet and ror (should) work well together. We have been eyeing datasweet with great interest.


(Cronin) #10

Yes they worked perfect before. But now I am experiencing the above error.