[DONE] Move settings to config/raedonlyrest.yml


(Askids) #22

@sscarduzio I tested with 1.16.12 on v5.5.1 of ES on windows 2012. I was able to move the config to separate readonlyrest.yml file and all rules were applied successfully. However, the keystore path resolution for enabling SSL seems to be completely broken now. Earlier, I was able to atleast give the full path and SSL was getting enabled. But now, it shows the error as given below.

[2017-10-25T16:56:30,502][INFO ][t.b.r.e.SSLTransportNetty4] SSL: attempting with JKS keystore..
[2017-10-25T16:56:30,507][ERROR][t.b.r.e.SSLTransportNetty4] Failed to load SSL certs and keys from JKS Keystore!

I had to rollback to 1.16.11 due to this error. Below is the keystore_file entry that i have in elasticsearch.yml file.

keystore_file: D:\Apps\Progra~1\Elasticsearch-5.5.1\config\my.keystore.jks

I also tried placing the keystore in the readonlyrest plugin folder with below entry and that also resulted in same error.

keystore_file: "plugins/readonlyrest/my.keystore.jks"

Let me know if you need any further details.


(Alexandra) #23

I am installing 1.16.18 and it is not even creating a readonlyrest.yml file, how can this be rectified please?


(Simone Scarduzio) #24

@alexa, you just need to create it yourself. Right beside the elasticsearch.yml.