Environmental Variables Not Recognized by SSL Settings

elasticsearch: 7.4.0
readonlyrest: 1.19.0

It appears that when configuring the readonlyrest.yml file environmental variables are not interpreted by the SSL settings (ssl, ssl_internode). Hard coding the values is successful.

Example Variables:

export SSL_VERIFY=false
export SSL_KEYSTORE=/usr/share/elasticsearch/config/certs/b74ee25fb7d7/b74ee25fb7d7.jks
export SSL_KEYSTORE_PASSWORD=changeme

Related settings of readonlyrest.yml:

    ssl:
      keystore_file: "${SSL_KEYSTORE}"
      keystore_pass: "${SSL_KEYSTORE_PASSWORD}"
      key_pass: ${SSL_KEYSTORE_PASSWORD}
      certificate_verification: ${SSL_VERIFY}

Hello @mgaetano, thanks for reporting this. It’s now in our backlog. This thread will be notified when done :slight_smile: