Error on kbn module install


(Simone Scarduzio) #21

@mdnuts are you too using the OSS version of Kibana?


(mdnuts) #22

no, i’m on the basic. hadn’t looked into oss versions.


(Simone Scarduzio) #23

OK guys I just reproduced this on a linux machine. Will report.


(Simone Scarduzio) #24

OK so the only error I get on Linux is the capitalization of connectorService, and I fixed it on the fly exactly like @mdnuts did.

The JSON.parse won’t happen. Everything works well in my environment.
@mdnuts maybe we can have a screenshare debug session?

PS: will release a new version with connectorService fixed as soon as possible.


(mdnuts) #25

i can’t, it’s air-gapped

for kicks i tried Edge - it at least gets me to the sign-in - then goes right into the loop of
myfqdn:5601/app/kibana/home?_g=0

firefox (my normal browser) just goes right to the home?_g=0


(Simone Scarduzio) #26

Can you take a pic (i.e. with your phone) of your YAML or report it exactly as YAML?


(Joe Bowman) #27

The capitalization change appears to have fixed things for me, thank you both.


(mdnuts) #28

(transposing, so i’m using 2 spaces for an indent.)

readonlyrest:
  ssl:
    enable: true
    keystore_file: keystore.jks"
    keystore_pass: readonlyrest
    key_pass: readonlyrest

  response_if_req_forbidden: Forbidden by ReadonlyREST ES Plugin

  access_control_rules:
  - name: "::LOGSTASH::"
    auth_key_sha256:  <key here that works>" #logstash:logstash
    actions: ["cluster:monitor/main","indices:admin/types/exists","indices:data/read*","indices:data/write/*","indices:admin/template/*","indices:admin/create"]
    indices: ["firewall*","switches*","unix*","windows*"]
    verbosity: error

  - name: "::FileBeat::"
    auth_key_sha256: <key - not working yet>
    actions: ["cluster:monitor/main","indices:admin/types/exists","indices:data/read*","indices:data/write/*","indices:admin/template/*","indices:admin/create"]
    indices: ["filebeat*"]
    verbosity: error

  - name: "::KIBANA-SRV::"
    auth_key: kibana:kibana

  - name: "::RO::"
    auth_key: ro:dev
    kibana_access: ro
    indices: [ ".kibana", ".kibana-devnull", "logstash-*"]
    kibana_hide_apps: ["readonlyrest_kbn", "timelion", "kibana:dev_tools", "kibana:management"]

  - name: "::RW::"
    auth_key: rw:dev
    kibana_access: rw
    indices: [".kibana", ".kibana-devnull", "logstash-*"]
    kibana_hide_apps: ["readonlyrest_kbn", "timelion", "kibana:dev_tools", "kibana:management"]

  - name: "::ADMIN::"
    auth_key: admin:dev
    kibana_access: admin

  - name: "::WEBSITE SEARCH BOX::"
    indices: ["public"]
    actions: ["indices:data/read/*"]

  - name: "Require HTTP Basic Auth"
    type: allow
    auth_key: elastic:whattheheck
    verbosity: error

(Simone Scarduzio) #29

So this message comes out in the browser console AND the kibana server output?


(mdnuts) #30

just on the browser console for firefox.

i don’t see anything in the kibana logs that indicates any problems.

looking at dev console in Edge I see

Resource violated directive 'script-src ‘unsafe-eval’ ’ in Content-Security-Policy: inline script, in http://myfqdn:5601/app/kibana at line 185 column 809. Resource will be blocked.
^ a single error about an inline script not firing due to content security policy is expected!

(both in bootstrap.js)

Then

unhandled promise rejection SyntaxError: Failed to Read.
[Object DOMException]: {code 12, message: “Failed to read.”, name: “SyntaxError”}

(on vendors.bundle.dll.js)


(Simone Scarduzio) #31

Can you see this image?
http://myfqdn:5601/plugins/readonlyrest_kbn/img/favicon.ico

I’m saying this because what seems to fail in your case is a piece of code that checks for the validity of the cookie which sends an ajax call to a dummy asset like the favicon.ico. If that fails, you are redirected to login. Which explains your loop.


(mdnuts) #32

interesting - no i can’t see the image.


(Simone Scarduzio) #33

OK I think the precedent import capitalisation error compromised the installation process. Will provide a new Enterprise plugin package and we start over.


(Simone Scarduzio) #34

https://readonlyrest-data.s3-eu-west-1.amazonaws.com/build/1.17.6-pre1/trial/20190422/enterprise/readonlyrest_kbn_enterprise-1.17.6-pre1-20190422_es6.7.0.zip?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAJEKIPNTOTIVGQ4EQ/20190422/eu-west-1/s3/aws4_request&X-Amz-Date=20190422T190144Z&X-Amz-Expires=604800&X-Amz-SignedHeaders=host&X-Amz-Signature=6a28092440ee1982a0a6f77c7ae1bc52afad5dbe6df3c156ae22601bd1a38fb7


(mdnuts) #35

no luck, but i do see the icon this time.


(Simone Scarduzio) #36

What do you mean? Same identical defect?


(mdnuts) #37

Yeah, exact same message.


(mdnuts) #38

Tomorrow I think I’m going to trash it all, get to 671 or 700 if you’re at that level, and install just the plugin after installing ES and getting the ES plugin in.


(Simone Scarduzio) #39

This is actually a good idea


(mdnuts) #40

can you send me the 6.7.1 enterprise plugin?