Have no popup basic auth window

Guys, please help me to understand what am I doing wrong. I’ve set up elasticsearch and kibana, I can login with curl to both, but from browser I expect to see or a special login page, or basic auth popup page, but I see only 401 (or 403) depends on prompt_for_basic_auth…

Elasticsearch, Kibana and plugin version is 7.10.1 free

cluster.name: ES
node.name: es-node-1
http.port: 9200
discovery.seed_hosts: ["", "", ""]
cluster.initial_master_nodes: ["", "", "", ""]
path.data: /mnt/data/elasticsearch
path.logs: /var/log/elasticsearch
path.repo: /mnt/data/elasticsearch/snapshot
bootstrap.memory_lock: true
action.destructive_requires_name: true
script.painless.regex.enabled: true
xpack.security.enabled: false

readonlyrest.yml (basic one from documentation)
  audit_collector: true
   - name: KIBANA_SERVER
     auth_key: kibana:kibana
     verbosity: error
   - name: PERSONAL_GRP
     groups: [ Personal ]
     kibana_access: rw
     kibana_hide_apps: [readonlyrest_kbn, timelion]
     kibana_index: '[email protected]{user}'
     verbosity: error
   - name: ADMIN_GRP
     groups: [Administrators]
     kibana_access: admin
     verbosity: error
   - name: Infosec
     groups: [ Infosec ]
     kibana_access: rw
     kibana_hide_apps: [ readonlyrest_kbn, timelion]
     kibana_index: .kibana_infosec
     verbosity: error
  - username: admin
    auth_key: admin:passwd
    groups: [Administrators, Infosec]
  - username: user1
    auth_key: user1:passwd
    groups: [Administrators, Personal, Infosec]

server.port: 5601
xpack.security.enabled: false
xpack.monitoring.enabled: true
xpack.graph.enabled: false
xpack.reporting.enabled: false
logging.json: false
server.host: "localhost" (or doesn't matter)
server.name: "ES"
elasticsearch.hosts: ["", "", "", ""]
elasticsearch.username: "kibana"
elasticsearch.password: "kibana"
logging.dest: /var/log/kibana/kibana.log

What I see in browser (no popup windows to put creds):
{"statusCode":401,"error":"Unauthorized","message":"forbidden: Response Error"}

What I see in curl:
[email protected]:~# curl -I -u kibana:kibana localhost:5601
HTTP/1.1 302 Found
location: /spaces/enter

[email protected]:~# curl -u kibana:kibana 3 64 0 0.00 0.22 0.29 cdhilmrstw - es-node-2 4 69 1 0.10 0.25 0.24 cdhilmrstw * es-node-1 4 65 0 0.04 0.14 0.16 cdhilmrstw - es-node-3 2 64 0 0.01 0.14 0.16 cdhilmrstw - es-node-4

What am I doing wrong?

Do you have Free ROR Kibana plugin installed?

No I don’t have kibana plugin installed, just elasticsearch one, as it’s written in official documentation

You know, we are not able to control how Kibana reacts on ES ROR responses. This was one of reasons why we released Free ROR Kibana plugin. I think you should install it: https://readonlyrest.com/free. When our plugin is installed on Kibana’s side, we can influence the default Kibana’s behaviour (in particular, handle cases like you described)

ROR Free for Kibana is not available yet for 7.10.1. We only have it available for up to 7.8.1.

We will release 7.9.x compatibility for ROR Enterprise Kibana plugins only initially, then for 7.10.x , and lastly we will release also ROR PRO and Free for 7.9 and 7.10

Seems the same situation as on - link

Thanks a lot for your help.

In my case it all worked after kibana downgrading to the version 7.8.1. Elasticsearch remains v. 7.10.1 with the ROR free plugin enabled with the same version. I didn’t set up kibana plugin - and HTTP basic auth popup window worked. After that I just installed ROR kibana plugin v7.8.1 and the difference is only that I see ROR login page instead of http basic auth popup window.

The case could be closed, once again thanks for your help.

1 Like