Message : logged in, but no identity metadata could be found


#1

Hi,

for QA purposes I tried to disable the ROR .
I logged on to kibana and from the readonlyrest menu on the left I set the “enable” parameter to false.
then I had to restart the kibana service , and from now on no one could login to kibana .
though the plugin was disabled it still pop up with username and password and when we put the credentials we get a message in the title .
if we press “OK” then we go back to the login screen.
if I run curl -XGET servername:port from command line then it’s ok . it doesn’t prompt from username or password and shows the standard json “… you know for search”.
is there anything else I should do to be able to login from kibana UI ?


(Simone Scarduzio) #2

If you put enable: false in ROR settings, you disable the ES plugin. The Kibana plugin should be disabled from kibana.yml


#3

thanks , which parameter should I set to “false” in the kibana YML ?
right now the kibana YML file has the standard parameters (server name , port etc … )


(Simone Scarduzio) #4

Checked the code, actually the only way to disable readonlyrest Enterprise is uninstalling the plugin at the time being.