No LDAP login error messages in ROR 7.0.0 pro

Hello everyone,

After switching from elastic/kibana-oss 6.5.4 to 7.0.0 the LDAP error messages from the login form disappeared on several of my servers, although I used exactly the same configuration in elasticsearch.yml, kibana.yml and readonlyrest.yml on all thoses servers.

If I use the right login credentials the connection goes very well, but if I make a typo I won’t get any answers the login page refresh and stays blank.

To check, I just deployed a server in 6.5.4 and a server in 7.0.0 (with the same config again) and the logins errors are visible on the 6.5.4 servers so my LDAP is working (still sending answers). The 7.0.0 server didn’t got any login error messages though, tried the same with a 7.2.0 elastack and I got the same problem : LDAP error messages are not displayed in the “form-message” span.

The only clue I got on the 7.0.0 serv is this error when I load the page :

SyntaxError: JSON.parse: unexpected end of data at line 1 column 1 of the JSON datalogin line 1 > scriptElement:7:33
fillAuthButtons http://192.168.126.136:5601/atlantic/login line 1 > scriptElement:7
<anonyme> http://192.168.126.136:5601/atlantic/login line 1 > scriptElement:17
ne http://192.168.126.136:5601/atlantic/login line 1 > scriptElement:1
Ae http://192.168.126.136:5601/atlantic/login line 1 > scriptElement:1
append http://192.168.126.136:5601/atlantic/login line 1 > scriptElement:1
html http://192.168.126.136:5601/atlantic/login line 1 > scriptElement:1
Ot http://192.168.126.136:5601/atlantic/login line 1 > scriptElement:1
html http://192.168.126.136:5601/atlantic/login line 1 > scriptElement:1
<anonyme> http://192.168.126.136:5601/atlantic/login line 1 > scriptElement:114
oo http://192.168.126.136:5601/atlantic/login line 1 > scriptElement:1
fireWith http://192.168.126.136:5601/atlantic/login line 1 > scriptElement:1
Jn http://192.168.126.136:5601/atlantic/login line 1 > scriptElement:1
Kn http://192.168.126.136:5601/atlantic/login line 1 > scriptElement:1

Anyone already got this bug or knows how to debug it ?

Regards,

Tim

I did an upgrade from 6.8.4 to 7.4.2 , and i do not meet your issue.

which part of plugin do you use ?
i mean which version on RoR ES, and which version on RoR kibana ?

for now i use 1.18.9 , and a 1.18.10 is coming. you can at least try with 1.18.9

Hey and thanks for your answer,

The login error messages are not working on two different type of server actually : one serv with kibana 7.0.0 and Ror ES/Ror Kibana 1.17.6 and the second serv is using kibana 7.2.0 and Ror Es/Kib 1.18.2.

I just tried to deploy a new serv with ES/kib 7.5.0 and Ror 1.18.9 and effectively it’s working now, so I understand that the Ror plugin version 1.17.6 and the ror plugin 1.18.2 are broken is that right ?

All my clusters are using elastack 7.2.0 and I would prefer to keep this version until the 8.0 stack come out.

each version of RoR have fix, and improvement. ( you can see them on download page https://readonlyrest.com/download/)

I recommend to you to update the RoR plugin (s - the elasticsearch one, and the kibana one) when you see a release.

remember to keep both version at same level.

regarding your edition of your stack ELK, don’t worry, you can downlaod the 1.18.9 RoR version , for your stack 7.2.0 (see the dropdown list of elk stack selection on download page)

for your 7.2.0 , i recommend you to wait for 1.18.10 , but if you are in urgency, get the 1.18.9 for now.

Oh so the version of the elastack and the version of both Ror plugins doesn’t have to be the same like it’s backwards compatible ?

I tried to use Ror 1.18.9 on my server with a 7.2.0 stack and i’m getting this error at start :

Exception
java.lang.IllegalArgumentException: Plugin [readonlyrest] was built for Elasticsearch version 7.5.0 but version 7.2.0 is running

So it doesn’t seems backwards compatbile, or maybe I should change the version number in the readonlyrest plugins manually ? But that doesn’t seems very practical.

Hi, i mean you have to download the good RoR build for your version of elk stack.

On the download page of RoR,
Select RoR version 1.18.9 ,
And select elk stack version 7.2

1 Like