Readonlyrest_kbn.proxy_auth_passthrough


#1

Can’t seem to get readonlyrest_kbn.proxy_auth_passthrough to work in version 1.16.16 (6.2.2).

kibana.yml:

elasticsearch.url: "http://localhost:9200"
elasticsearch.requestHeadersWhitelist: [‘authorization’, ‘X-Forwarded-User’]
readonlyrest_kbn.proxy_auth_passthrough: true
elasticsearch.username: "XXX"
elasticsearch.password: “XXX”

But Kibana still keeps presenting the logon window. Am I doing something wrong?


(Simone Scarduzio) #2

Hi @trondvh,
Two things: Kibana always wants lowercase headers names in settings for some reason, and: is your reverse proxy sending the header to Kibana? Also, make sure the rev prosy is redirecting users to /login right after the authentication.