Self Signed SSL Certificate Error


#1

Hi, I am having a problem with the kibana plugin. I had it working without the plugin. My setup is using LDAP authentication and SSL is enabled with a self signed certificate.

I have added both of these options in kibana.yml but still not working:

elasticsearch.ssl.verificationMode: none
elasticsearch.ssl.verify: False

This is the error: Could not login: Client request error: self signed certificate

Is there another option that I am missing?

Please let me know if you need additional information to help troubleshoot this problem.

Thanks.


(Simone Scarduzio) #2

Hello @ed0, interesting bug and well reported too. :thumbsup:

I made it so that now ROR for Kibana reads Kibana settings and if verificationMode is ‘none’, then it behaves accordingly in the authentication phase too.

Please find ROR for Kibana 0.1.3 available in Plasso for you and the rest of the PRO customers.


#3

Great, it is working now with the latest version. Thanks!

I am confused about one thing in the instructions for the kibana plugin. Can you clarify what this block does since the comment says that admin access is needed to use the kibana app. The app seems to work with or without this block.

- name: "::ADMIN::"
  auth_key: admin:dev
  # KIBANA ADMIN ACCESS NEEDED TO USE THE ROR KIBANA APP!
  kibana_access: admin

(Simone Scarduzio) #4

Yes i’t badly explained in a crappy comment, I should expand on that. Thanks for bringing it out.

The admin kibana_access is needed for a user to be able to save the settings from the readonlyrest_kbn app. The login/logout and hide apps features don’t need an administrator even to exist.