1.19.1 and Kibana sessions stored in ES index


we setup 1.19.1 and Kibana 6.8.4
but i don’t see index for storing session in ES

GET _cat/indices/.readonlyrest *

and i don’t understand how its work

have messages:

‘[index_not_found_exception] no such index, with { resource.type=“index_or_alias” & resource.id=".readonlyrest_kbn_sessions" & index_uuid=“na” & index=".readonlyrest_kbn_sessions" }’

if I create index manualy

have another message

[query_shard_exception] No mapping found for [expiresAt] in order to sort on, with { index_uuid=“8vG-_GWFQZGicq88vfaOHA” & index=".readonlyrest_kbn_sessions" }

Hello @skks,

The “.readonlyrest” index is where ReadonlyREST PRO/Enterprise plugin for Kibana stores the global YAML settings (which normally are set insid readonlyrest.yml text file in every ES node).

This index is created and populated solely by the ReadonlyREST Kibana application (settings editor).

I.e. this view:

When present, the settings found in the “.readonlyrest” index take priority over the ones found in the readonlyrest.yml

i’m about saving session with multiple kibana instances


Ok so you want to have multiple Kibana instances (maybe behind a load balancer?). Then I suggest adding these two lines in kibana.yml

  • readonlyrest_kbn.cookiePass: "generatedStringIn1step" (example: “12345678901234567890123456789012”)
  • readonlyrest_kbn.store_sessions_in_index: true (enable session storage in index)

Now the sessions are going to be saved in the .readonlyrest_kbn_sessions index in Elasticsearch.

Remember that the cookiePass needs to be the same between all Kibana instances. So they can correctly to decypher the cookie and the encrypted in-index cache.

yes, of course

i use easy config for test:

readonlyrest_kbn.session_timeout_minutes: 4320
readonlyrest_kbn.clearSessionOnEvents: [“never”]
readonlyrest_kbn.cookiePass: “12345678901234567890123456789012”
readonlyrest_kbn.store_sessions_in_index: true

and have message

index .readonlyrest_kbn_sessions
don’t create by service Kibana with readonlyrest plugin

OK this issue with throwing errors when the index is empty or inexistent is fixed in 1.19.2 we released yesterday. Could you install that please and try again?

Update only kibana plugin to 1.19.2


  1. index don’t created
  2. session manager not worked

have some error:
{“type”:“error”,"@timestamp":“2020-03-05T14:25:12Z”,“tags”:[“warning”,“process”],“pid”:202285,“level”:“error”,“error”:{“message”:“Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 5)”,“name”:“UnhandledPromiseRejectionWarning”,“stack”:“TypeError: Unable to build a path with those params. Supply at least index, type, id\n at exec (/usr/share/kibana/node_modules/elasticsearch/src/lib/client_action.js:302:11)\n at EsApiClient.action (/usr/share/kibana/node_modules/elasticsearch/src/lib/client_action.js:62:16)\n at callAPI (/usr/share/kibana/src/legacy/core_plugins/elasticsearch/lib/cluster.js:128:14)\n at Cluster.callWithInternalUser (/usr/share/kibana/src/legacy/core_plugins/elasticsearch/lib/cluster.js:86:12)\n at EsClient.removeFromIndex (/usr/share/kibana/plugins/readonlyrest_kbn/server/routes/lib/EsClient.js:24:35)\n at IndexBasedSessionManager.delete.sid [as delete] (/usr/share/kibana/plugins/readonlyrest_kbn/server/routes/lib/sessionManager/IndexBasedSessionManager.js:48:19)\n at clearSession (/usr/share/kibana/plugins/readonlyrest_kbn/server/routes/lib/identityManager.js:497:5)\n at Object.getIdentityFromCookie (/usr/share/kibana/plugins/readonlyrest_kbn/server/routes/lib/identityManager.js:413:7)\n at postAuth (/usr/share/kibana/plugins/readonlyrest_kbn/server/routes/lib/postAuth.js:16:46)\n at module.exports.internals.Manager.execute (/usr/share/kibana/node_modules/hapi/lib/toolkit.js:35:106)\n at Request._invoke (/usr/share/kibana/node_modules/hapi/lib/request.js:293:55)”},“message”:“Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 5)”}

@skks I have a new build for you. Can you send me a PM in the forum with your subscription type (free, pro, enterprise) and the name of your company?

We seem to be running into the same issue
RoR Enterprise 1.19.2
Kibana 6.8.0
Elasticsearch 6.8.0

We have a seperate test environment available where we could test a fix for you if necessary.

Upon posting this I see 1.19.3 is out as well.
Will download this and check!

It seems there is a new version, but upon downloading it downloads as 1.19.2 again?
On the download page it also says 1.19.2 twuce now?

Hey @ronald.vanboven, the glitch is resolved. Sorry about that.

Perfect, will download and test later today.
I will report back here if it solves our issue.

Yes, in 1.19.3 and 6.8.0 this works now.
Thank you!

1 Like