Elastic search input to logstash


(Dinesh) #1

I Installed read-only rest plugin for Elastic search 5.6.1

And I changed elasticsearch.yml file for security and SSL.
They are working fine but SSL I generated locally.
When I am using elastic search as output in logstash I am using below method to escape SSL verification.

ssl_certificate_verification => false

When I am using the same thing in Elastic Search input for logstash it’s not working, Please suggest me what I am missing in below elastic search input for logstash.

input {
elasticsearch {
hosts => [ “https://127.0.0.1:9200” ]
ssl => true
ssl_certificate_verification => false
index => “logstash-index1”
user => “XXXXXXX”
password => “XXXXXXX”
size => 1000
scroll => “5m”
docinfo => true
}
}


(Simone Scarduzio) #2

Hello @DineshAngari,

I’m not sure Logstash has the certificate validation flag implemented in Elasticsearch input. At least in the documentation is not mentioned (as of today).

https://www.elastic.co/guide/en/logstash/current/plugins-inputs-elasticsearch.html#plugins-inputs-elasticsearch-ssl

Perhaps you could ask Elastic to add it?


(Dinesh) #3

Thanks for your reply,Let me post in elastic search