Elasticsearch 6.3 cluster not coming up after installing latest plugin


#1

Hi,

I have downloaded installed 6.3 elasticsearch and the plugin. I created readonlyrest.yml file in the same directory where elasticsearch.yml resides. I am running a 3 node cluster in my vm. I made the following changes in the readonlyrest.yml file;

readonlyrest:
  enable: false
  access_control_rules:
    - name: admin
      indices: ["*"]
      kibana_access: admin
      auth_key_sha256: 8da193366e1554c08b2870c50f737b9587c3372b656151c4a96028af26f51334
    - name: readonly
      indices: ["*"]
      kibana_access: ro_strict
      actions: ["indices:data/read/*"]
      auth_key_sha256: d4663826bbad2aef89ef8ec5beca0b50685064f6eb70f3018bb179320fe3c60b

After this, I restarted my cluster, but elasticsearch is not accessible. My cluster is fresh new without any indices.

[2018-06-20T17:50:13,015][INFO ][t.b.r.e.IndexLevelActionFilter] [ga63_node_1] Settings observer refreshing...
[2018-06-20T17:50:13,022][INFO ][t.b.r.e.IndexLevelActionFilter] [ga63_node_1] Configuration reloaded - ReadonlyREST disabled
[2018-06-20T17:50:13,022][INFO ][t.b.r.e.IndexLevelActionFilter] [ga63_node_1] Readonly REST plugin was loaded...
[2018-06-20T17:50:13,301][DEBUG][o.e.a.ActionModule       ] Using REST wrapper from plugin org.elasticsearch.xpack.security.Security
[2018-06-20T17:50:13,301][DEBUG][o.e.a.ActionModule       ] Using REST wrapper from plugin tech.beshu.ror.es.ReadonlyRestPlugin
[2018-06-20T17:50:13,315][WARN ][o.e.b.ElasticsearchUncaughtExceptionHandler] [ga63_node_1] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalArgumentException: Cannot have more than one plugin implementing a REST wrapper
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:140) ~[elasticsearch-6.3.0.jar:6.3.0]
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:127) ~[elasticsearch-6.3.0.jar:6.3.0]
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-6.3.0.jar:6.3.0]
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-6.3.0.jar:6.3.0]
        at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-6.3.0.jar:6.3.0]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:93) ~[elasticsearch-6.3.0.jar:6.3.0]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:86) ~[elasticsearch-6.3.0.jar:6.3.0]
Caused by: java.lang.IllegalArgumentException: Cannot have more than one plugin implementing a REST wrapper
        at org.elasticsearch.action.ActionModule.<init>(ActionModule.java:381) ~[elasticsearch-6.3.0.jar:6.3.0]
        at org.elasticsearch.node.Node.<init>(Node.java:412) ~[elasticsearch-6.3.0.jar:6.3.0]
        at org.elasticsearch.node.Node.<init>(Node.java:252) ~[elasticsearch-6.3.0.jar:6.3.0]
        at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:213) ~[elasticsearch-6.3.0.jar:6.3.0]
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:213) ~[elasticsearch-6.3.0.jar:6.3.0]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:326) ~[elasticsearch-6.3.0.jar:6.3.0]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:136) ~[elasticsearch-6.3.0.jar:6.3.0]
        ... 6 more
[2018-06-20T17:50:14,032][INFO ][t.b.r.c.s.SettingsPoller ] [CLUSTERWIDE SETTINGS] Cluster not ready...
[2018-06-20T17:50:15,033][INFO ][t.b.r.c.s.SettingsPoller ] [CLUSTERWIDE SETTINGS] Cluster not ready...
[2018-06-20T17:50:16,034][INFO ][t.b.r.c.s.SettingsPoller ] [CLUSTERWIDE SETTINGS] Cluster not ready...
[2018-06-20T17:50:17,034][INFO ][t.b.r.c.s.SettingsPoller ] [CLUSTERWIDE SETTINGS] Cluster not ready...
[2018-06-20T17:50:18,035][INFO ][t.b.r.c.s.SettingsPoller ] [CLUSTERWIDE SETTINGS] Cluster not ready...
[2018-06-20T17:50:19,036][INFO ][t.b.r.c.s.SettingsPoller ] [CLUSTERWIDE SETTINGS] Cluster not ready...

I am unable to access my nodes now. How can I fix this?

Thank you.


(Simone Scarduzio) #2

HI @gitime with Elasticsearch 6.3.x they pre-installed X-pack, so you need to disable at least x-pack security.

Append this to elasticsearch.yml

xpack.security.enabled: false 

And if you are using Kibana, download the one without x-pack installed: https://www.elastic.co/downloads/kibana-oss


#3

Hi @sscarduzio , Ok, I can use Kibana OSS. I would like to use free x-pack monitoring feature. How can I enable it in oss?

Than you.


(Simone Scarduzio) #4

I don’t think you can unfortunately. I am currently struggling to make ROR work in non-OSS Kibana, but for now I cannot disable x-pack security module for some reason.

edit: in order for ROR to work with 6.3.x and x-pack, you need to add xpack.security.disabled: true to BOTH elasticsearch.yml and kibana.yml

Can you try @gitime?