Hangs on "Optimizing and caching bundles"


(Cronin) #1

I upgraded to version 6.5.1 this am. I had no problem with Elastic but Kibana isent working. When I check the Server log I notice that it seems like it’s hanging on “Optimizing and caching bundles for stateSessionStorageRedirect, status_page, timelion, space_selector, dashboardViewer, apm, canvas, infra, readonlyrest_kbn and kibana. This may take a few minutes”

Any help would be great. I have tried removing the budle files manually and rebooting and I get the same problem.


(Cronin) #2

I think I figured it out when installing the plugin on linux you need to run the command like so 'sudo -u kibana bin/kibana-plugin install x-pack" IE set the user. This seems to have fixed things.


(Cronin) #3

One more question. Now that everything is working I keep getting this popup no matter if I hit yes or no. Anything that I can do about it?


(Simone Scarduzio) #4

OK this is new to me, will try to reproduce


(Cronin) #5

Looks like I have the same problem with “Canvas”
"Error 400 Bad Request: mapping set to strict, dynamic introduction of [canvas-workpad] within [doc] is not allowed: "


(Cronin) #6

A quick update here. I figured out how to trigger this error. If you are logged in as a user and viewing a specific “tenancy”. If I login as the master user I don’t get this problem.


(Cronin) #7

simone,
In addition to all of this I can’t seem to create index patterns either getting the following error in console:

Let me know if it’s something I’m doing?


(Paul) #8

The issue isnt related to the plugin being installed. Even without the plugin - doing an upgrade from 6.4.X to 6.5.0 or 6.5.1 is giving many users the same issue.


(Cronin) #9

@trouble Do you have a link to where I can see this on the elastic forum or somthing? I would like to follow along to see if it gets resolved and how.


(Paul) #10

Hi

They state to upgrade to 6.5.2.


(Cronin) #11

Thanks Paul.

If that’s the case @sscarduzio any news on a 6.5.2 release?


(Simone Scarduzio) #12

Hi @cronin and @trouble,
Will create a new release tonight, and we will go straight to support 6.5.3


#13

How did you get this to work? When I attempt it with 6.4.2, I get the following;

[[email protected] centos]# sudo -u kibana /usr/share/kibana/bin/kibana-plugin install file:///tmp/readonlyrest_kbn_enterprise-1.16.28_es6.4.2.zip
Attempting to transfer from file:///tmp/readonlyrest_kbn_enterprise-1.16.28_es6.4.2.zip
Transferring 6746248 bytes…
Transfer complete
Retrieving metadata from plugin archive
Extracting plugin archive
Extraction complete
Optimizing and caching browser bundles…
Plugin installation was unsuccessful due to error "Command failed: /usr/share/kibana/node/bin/node /usr/share/kibana/src/cli --env.name=production --optimize.useBundleCache=false --server.autoListen=false --plugins.initialize=false --uiSettings.enabled=false
(node:28004) [DEP0022] DeprecationWarning: os.tmpDir() is deprecated. Use os.tmpdir() instead.
FATAL { Error: EACCES: permission denied, rmdir ‘/usr/share/kibana/optimize/bundles/src/ui’
errno: -13,
code: ‘EACCES’,
syscall: ‘rmdir’,
path: ‘/usr/share/kibana/optimize/bundles/src/ui’ }

"


(Simone Scarduzio) #14

@atownsend yours seems another issue, i.e. about unix filesystem permissions


(Simone Scarduzio) #15

Just released 1.16.31, with 6.5.3 compatibility.


(Cronin) #16

as an FYI The upgrade didn’t actually fix the error. I ended up blowing out all the indexes for kibana and ROR and that fixed it all. Looks to be working perfect now!