How to disable readonlyrest?


How to disable readonlyrest?

I tried to put “readonlyrest.enable: false” in elasticsearch.yml and “readonlyrest.enable: false” in readonlyrest.yml ; but it seems that readonlyrest is still initialized and enabled.

I say that because I can see in the logs: " ROR main engine (id=19d0334d2409f71ea9d57b5eb8aacecc132af9b4) was initiated."
And also, I find readonlyrest classes in the elasticsearch stack trace logs.

So is there another configuration to do?

ROR version: 1.42.0
ES version: 7.17.5

Hi @fbaligand

When you disable (you should do it in readonlyrest.yml or KBN settings editor) ROR you disable its ACL, not the whole ROR plugin. ROR is still working (it’s exposing internal API or polling for in-index settings changes), but it’s just proxying requests to ES. You can call some ES API without credentials and check.

But it looks like our logs could be improved to show that clearly. We will do it. Thanks for pointing this out

1 Like

Hi @coutoPL

Thanks for your precise answer and your reactivity.
It’s now clear to me.

Then, as you say, it would be great to add a log that explicitly says that ROR is disabled.