[Issue] Installing ROR Enterprise Plugin


(Salko Nuhanovic) #1

Hi Guys,

I am having issues by installing the Kibana ROR Enterprise plugin (readonlyrest_kbn_enterprise-1. 17.6-20190502_es6.7.1)
The installation of the corresponding ES plugin was fine, but upon starting Kibana I am getting following error:

ROR log level:  info
{"type":"log","@timestamp":"2019-05-09T13:30:22Z","tags":["fatal","root"],"pid":1,"message":"Error: custom client factory is already set, unable to replace the current one\n    at ScopedSavedObjectsClientProvider.setClientFactory (/usr/share/kibana/src/server/saved_objects/service/lib/scoped_client_provider.js:29:13)\n    at Object.setScopedSavedObjectsClientFactory (/usr/share/kibana/src/server/saved_objects/service/create_saved_objects_service.js:87:75)\n    at /usr/share/kibana/plugins/readonlyrest_kbn/index.js:1:4564\n    at Plugin.init [as externalInit] (/usr/share/kibana/plugins/readonlyrest_kbn/index.js:1:4420)"}

 FATAL  Error: custom client factory is already set, unable to replace the current one

I disabled the xpack security feature (via xpack.security.enabled=false), did i missed something else?

Thank you in advance.


(Simone Scarduzio) #2

It’s YAML, so it needs colon, not equals sign.

xpack.security.enabled: false

(Salko Nuhanovic) #3

Hi Simone!

I am totally aware about that. Surely I used the correct format, but it still didnt worked for me.
Upon installing the OSS version of the Kibana Image (v. 6.7.1) it worked fine.
Is there any recommendation which version to use ?


(Simone Scarduzio) #4

Hi @salkonuhannovic,

I downloaded and tested the trial package you showed for 6.7.1. It worked well for me.
Here is my configuration (without the comments)

 $ egrep -v "^\s*(#|$)" config/kibana/kibana.yml
server.host: 0.0.0.0
elasticsearch.username: "kibana"
elasticsearch.password: "kibana"
xpack.security.enabled: false

$ egrep -v "^\s*(#|$)" config/elasticsearch/elasticsearch.yml
cluster.name: es-all-in-one
node.name: es-all-one-1
path.data: /var/lib/elasticsearch
path.logs: /var/log/elasticsearch
network.host: _local_,_site_
xpack.security.enabled: false

$ egrep -v "^\s*(#|$)" config/elasticsearch/readonlyrest.yml
readonlyrest:
  prompt_for_basic_auth: false
  access_control_rules:
  - name: "::KIBANA::"
    auth_key_sha256: "ab8aa94dd63debfa31ef8a9eae9582dcb252c06cdb6313e123546cc8edfeaf3e"


  - name: "Admin"
    groups: ["useradmin"]
    kibana_access: admin
    kibana_index: ".kibana_useradmin"

  users:
  - username: admin
    auth_key_sha256: "8da193366e1554c08b2870c50f737b9587c3372b656151c4a96028af26f51334"
    groups: ["useradmin"]