Kibana mutitenancy - problem with readonly user


I found a problem with multitenancy in Kibana version 6.5.4. I want to set a new group with a new Kibana index. At first I prepared a visualisation and a dashboaard with user “TEST admin”. Then I tried to look to the kibana with user “TEST” and the Kibana show me an error.

Unable to update UI setting
Unexpected token < in JSON at position 0

When I tried to set readonly user for default kibana index it was OK.

Can you help me with this problem please?

part of configuration:
enable: true
keystore_file: “/srv/app/keystore/keystore.jks”
keystore_pass: xxx
key_pass: xxx
key_alias: int

prompt_for_basic_auth: false
response_if_req_forbidden: Forbidden by ReadonlyREST ES plugin

- name: Accept requests from admin users
    name: "ldap1"
    groups: ["ELASTICSEARCH_Admins"]
  type: allow
  indices: ["*"]

- name: TEST admin
  auth_key_sha256: "5acbee49f3760bd5724a82e07798a1b9f57a318611108167d7305830424a08a9"
  kibana_access: admin
  indices: [".kibana_test", "eltrack-cep*"]
  kibana_index: ".kibana_test"

- name: TEST
  auth_key_sha256: "31f014b53e5861c8b28a8707a1d6a2a2737ce2c22fd671884173498510a063f0"
  kibana_access: ro
  kibana_hide_apps: ["readonlyrest_kbn", "timelion", "kibana:dev_tools", "kibana:visualize", "canvas", "apm", "monitoring", "kibana:management", "infra:home","infra:logs","ml", "kibana:discover"]
  indices: [".kibana_test", "eltrack-cep*"]
  kibana_index: ".kibana_test"

Hi @Zenisek, welcome to the forum! Please can you share what ROR version are you using? You can discover it looking into the plugins folder in both kibana and elasticsearch.

  • Kibana: grep version $KBN_HOME/plugins/readonlyrest_kbn/package.json
  • Elasticsearch grep version $ES_HOME/plugins/readonlyrest/*properties

Hi @sscarduzio,
grep version $KBN_HOME/plugins/readonlyrest_kbn/package.json
“version”: “1.19.3”,
“version”: “6.5.4”

grep version $ES_HOME/plugins/readonlyrest/*properties

All right, great I asked actually. Can you please update to 1.19.4? We fixed quite a few related things in the meantime.

Please update both ES and Kibana plugins, otherwise it won’t work.