Kibana plugin doesn't work on a node which was added to the cluster


#1

Hello ,

I have a cluster containing some hosts working with ROR and kibana plugin , both are version 1.16.27 .
suppose the hosts of the cluster are host_a , host_b and host_c .
I’ve started kibana service in each of them .
If I browse host_a:5601 or host_b:5601 or host_c:5601 then it works fine for me , I put my username and password and start working .
yesterday I added another host , host_d . I’ve started the kibana service .
if I run curl -u username:passwrod -XGET host_d:9200 then it’s ok and I get the result.
if I browse host_d:5601 then I prompted for user and password but get Error 404 .
If in host_d , I change the kibana.yml settings and set “elasticsearch.url” to host_a:9200 then restart kibana service and browse to host_d:5601 then login is successful and I don’t get the error 404 message.
when I compare the kibana.yml files of host_a and host_d I see no difference except the elasticsearch.url and server.host parameters .

can you please help ?


(Simone Scarduzio) #2

@sdba2 can you make sure that the ROR plugin is installed and loaded correctly (see logs) in the node that gives 404?


#3

I dindn’t check the logs , but when I ran : curl -u user:password -XGET host_d:9200 it owrked fine for me and I got the json output from the cluster .
I think that means that the ROR plugin is installed correctly . am I right ?


#4

sorry , my mistake .
I usually run the elasticsearch and ror using automatic install .
somehow the installation of the last host I’ve added didn’t install ROR .
I’ll check and update again .


#5

ok , found that .
it was the missing installation of the ROR . now it’s ok.
thanks for helping .