Kibana refreshing/reloading every few minutes

Hi @sscarduzio

We just upgraded kibana from 7.6.2 to 7.15.1.

We noticed that the kibana page is refreshing/reloading every 1,2 or 3 minutes.

Any idea about? I’m not finding any topic related to that.

Thanks

Hello Nadine, nice to hear from you.

Not sure if this is the specific case, but Kibana dashboards can auto refresh if configured to do so (see “refresh every”).

If this is not the case, can you get any more information from browser console logs? (F12 in Chrome)

Thanks for your quick reply.

I think this case is specific to the dashboard. But our concern is that, the entire page refreshs.

Here is what happens every time the page is reloaded:

Hi @Nadine,

OK because it’s going through full refreshes, the console log data resets every time, so we can’t see the logs of right before refreshing. You will need to:

  • tick “Preserve log”

  • Clear console logs with the :no_entry_sign: button

  • Wait for the spontaneous refresh

  • Copy all the content of the console here

Hi @sscarduzio

It looks like the message in the console is not related to the refresh problem, we finally noticed that there were double quotes ("") missing in readonlyrest config.
Thanks for your support.

Happy you resolved Nadine, good job!

Where in the config were the double quotes missing? Now I’m curious!

1 Like

Hi @sscarduzio

Here:

 - name: "::Kibana-Lecture::"
   type: allow
   ldap_authentication: "ldap_el"
   indices: ["rq-ial*","rq-strurl*",rq-syslog*, "rq-ctm*",","rq-puppet*","rq-log-puppet*","rq-m2*",".kibana*"]
   kibana_index: ".kibana_publique"

On rq-syslog

1 Like

Hello there!
I have stumbled on same error. double check .yml file and there seems to be no errors or missed qoutes. i can attach logs like you asked before.

Navigated to http://localhost:5601/s/default/app/home
home#/:286 Refused to execute inline script because it violates the following Content Security Policy directive: "script-src 'self' 'unsafe-eval'". Either the 'unsafe-inline' keyword, a hash ('sha256-P5polb1UreUSOe5V/Pv7tc+yeZuJXiOi/3fqhGsU7Be='), or a nonce ('nonce-...') is required to enable inline execution.

DevTools failed to load source map: Could not load content for chrome-extension://gighmmpiobklfepjocnamgkkbiglidom/browser-polyfill.js.map: System error: net::ERR_FILE_NOT_FOUND
bootstrap.js:42 ^ A single error about an inline script not firing due to content security policy is expected!

Hello @Darius,

Welcome to the forum! If you are an Enterprise or PRO user, please open a ticket from the customer portal so that your case is treated with the appropriate priority.

The log you show is entirely normal. Did you use preserve log in chrome dev tools?

yes. i have checked “preserve log” tick. i am not Enterprise or Pro user. Just trying this tool to see if it useful for us. We are using ELK 8.5.2

edit:
and this happens only with users who are logged in using LDAP.

“googling errors for 4 hours can save you 10 minutes of reading documentation”… my ACL block ordering was bad…

That makes sense! Order is super important.

This is so true in my direct experience as well! This is why the forum is so important for us.
We always recommend to Enterprise users to bring their support case to the publicly accessible forum because their experience can be useful to the future googlers (which includes them).

Nowadays Enterprise tickets are handled as forum private messages (rather than traditional emails), so when we find a solution, we can invite the user to strip any identifiables info, and transform the PM thread to public thread.