Missing ACL rules


(Jakub) #1

When trying to update ACL rules through Kibana ROR plugin, elasticsearch skips few rules.
For example, here is a part from configuration from Kibana (changed passwords to xyz):

- name: "::ELK-AGENT::"
  auth_key: elkagent:xyz

- name: "::PYTHON::"
  auth_key: python:xyz
  verbosity: error

- name: "::PYTHON-CORRECTOR::"
  auth_key: python_corrector:xyz

- name: "::PYTHON-LATENCY::"
  auth_key: python_latency:xyz

 - name: "::PYTHON-CURATOR::"
  auth_key: python_curator:xyz

- name: "::APPLE::"
  auth_key: apple:xyz

- name: "::SPM::"
  auth_key: SPM:xyz

In elasticsearch logs few rules are missing (PYTHON-LATENCY, PYTHON-CURATOR, APPLE):

[2019-02-18T14:30:39,713][INFO ][t.b.r.a.ACL ] ADDING BLOCK: { name: ‘::ELK-AGENT::’, policy: ALLOW, rules: [auth_key]}
[2019-02-18T14:30:39,713][INFO ][t.b.r.a.ACL ] ADDING BLOCK: { name: ‘::PYTHON::’, policy: ALLOW, rules: [auth_key]}
[2019-02-18T14:30:39,713][INFO ][t.b.r.a.ACL ] ADDING BLOCK: { name: ‘::PYTHON-CORRECTOR::’, policy: ALLOW, rules: [auth_key]}
[2019-02-18T14:30:39,713][INFO ][t.b.r.a.ACL ] ADDING BLOCK: { name: ‘::SPM::’, policy: ALLOW, rules: [auth_key]}

Any ideas of the reason?
I check that there aren’t any special characters in missing rules.


(Jakub) #2

I think it may be interesting - didn’t expect it would help, but I tried to update settings several times without changing the configuration, just clicking Save button, and after one of the tries all rules has been applied. No idea why.


(Simone Scarduzio) #3

Strange! Can you exclude also that you somehow resolved any indentation errors in the process?