Problem with ROR 1.15.1 pre2 and Kibana plugin


(Nan008) #1

Hello,

I installed the 1.15.1 pre 2 that you provided (Thank you! by the way), as ES plugin 1.15.0 was problematic with user/groups access rules

And started testing Kibana plugin with this

Kibana is displaying the pro login site - which looks very nice the problem is on ES side with the plugin 1.15.1 pre2

elasticsearch.yml


readonlyrest:
    enable: true

    response_if_req_forbidden: Forbidden by ReadonlyREST ES plugin

prompt_for_basic_auth: false

access_control_rules:
    - name: Accept all requests for indecies
      type: allow
      hosts: [xx.x.xxx.113]

    - name: Kibana Server
      type: allow
      auth_key: kibana:kibana

kibana.yml

server.host: "xx.x.xxx.104"

# The Kibana server's name.  This is used for display purposes.
server.name: "Kibana Server"

# The URL of the Elasticsearch instance to use for all your queries.
elasticsearch.url: "http://xx.x.xxx.113:9200"

elasticsearch.username: "kibana"
elasticsearch.password: "kibana"

elasticsearch.ssl.verify: false

error I am getting with this

[2017-05-25T11:35:44,954][INFO ][o.e.p.PluginsService ] [4DfeseL] loaded plugin [readonlyrest] [2017-05-25T11:35:45,868][ERROR][o.e.b.Bootstrap ] Exception java.lang.IllegalArgumentException: unknown setting [access_control_rules.0.hosts.0] please check that any required plugins are installed, or check the breaking changes documentation for removed settings at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:293) ~[elasticsearch-5.4.0.jar:5.4.0] at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:256) ~[elasticsearch-5.4.0.jar:5.4.0] at org.elasticsearch.common.settings.SettingsModule.<init>(SettingsModule.java:139) ~[elasticsearch-5.4.0.jar:5.4.0] at org.elasticsearch.node.Node.<init>(Node.java:342) ~[elasticsearch-5.4.0.jar:5.4.0] at org.elasticsearch.node.Node.<init>(Node.java:242) ~[elasticsearch-5.4.0.jar:5.4.0] at org.elasticsearch.bootstrap.Bootstrap$6.<init>(Bootstrap.java:242) ~[elasticsearch-5.4.0.jar:5.4.0] at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:242) ~[elasticsearch-5.4.0.jar:5.4.0] at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:360) [elasticsearch-5.4.0.jar:5.4.0] at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:123) [elasticsearch-5.4.0.jar:5.4.0] at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:114) [elasticsearch-5.4.0.jar:5.4.0] at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:67) [elasticsearch-5.4.0.jar:5.4.0] at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122) [elasticsearch-5.4.0.jar:5.4.0] at org.elasticsearch.cli.Command.main(Command.java:88) [elasticsearch-5.4.0.jar:5.4.0] at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91) [elasticsearch-5.4.0.jar:5.4.0] at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84) [elasticsearch-5.4.0.jar:5.4.0]

and Kibana is reacting to this as well with error


(Simone Scarduzio) #2

Hello @nan008, I’ll have a look right now :slight_smile:


(Simone Scarduzio) #3

OK I think it’s an indentation problem. Try this

readonlyrest:
    enable: true

    response_if_req_forbidden: Forbidden by ReadonlyREST ES plugin

    prompt_for_basic_auth: false

    access_control_rules:
    - name: "Accept all requests for indices"
      type: allow
      hosts: ["xx.x.xxx.113"]

    - name: "Kibana Server"
      type: allow
      auth_key: kibana:kibana

I also added double quotes around the strings, to prevent any possible YAML parsing headache.


(Nan008) #4

Thank you, the double quotes actually fixed the issue.

Also with this version the users/groups seems to work. Now I need to figure out where to put kibana_hide_apps: [timelion, ‘kibana:devtools’, ‘kibana:managment’] for users :).
As Kibana is giving me the error.