Problem with RoR install on 7.5.0 elasticsearch node

Trying to install 1.18.9 plugin on a node running 7.5.0. Had to switch from the java shipped with ES as it was broken for several reasons - am using java-1.8.0-openjdk-1.8.0.232.b09-0.el7_7.x86_64 which is the latest java for this CentOS 7.7 system.

Starting ES I get a bunch of stack traces but the key error looks to be:

Caused by: java.lang.UnsupportedClassVersionError: tech/beshu/ror/Constants has been compiled by a more recent version of the Java Runtime (class file version 53.0), this version of the Java Runtime only recognizes class file versions up to 52.0

Suggestions? I had RoR running on 7.4 previously (different system) using the system java. I tried to download the 7.4.2 and see if I could downgrade ES and have it start working again, but I got a “Oops something went wrong. Contact us directly” message on the download page.

Suggestions?

@cmh this is really weird. It looks like Constants class was compiled using java 9. I don’t know how it happened. I’ve checked 7.4.2 and it looks OK.

Here is direct link:
https://readonlyrest-data.s3-eu-west-1.amazonaws.com/build/1.18.9/readonlyrest-1.18.9_es7.4.2.zip?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIA5SJIWBO54AGBERLX/20191218/eu-west-1/s3/aws4_request&X-Amz-Date=20191218T205100Z&X-Amz-Expires=604800&X-Amz-SignedHeaders=host&X-Amz-Signature=206a279b5ffbc82a6570dcd0a1d7c8792cfb7358e3aeaaf5a0b144c9c24ad683

I’ll check what is going on with 7.5.0 and let you know when it is fixed.

1 Like

My fault. I built it manually from my laptop because 1.18.9 was released just before 7.5.0 was available. So I backported it. :man_facepalming:

1 Like

Thanks, I’ll try it tomorrow. Tried to go back to 7.4.2 but the system kept complaining that I couldn’t downgrade which is weird as I fully uninstalled elasticsearch and zeroed out the data directory completely. Unsure where it was storing the 7.5.0 information, especially since it hadn’t succeeded in fully starting! Hopefully going back to 7.5.0 with the new download everything will be roses and happiness!

Wait, what am I talking about, this is elasticsearch. :smiley:

Have you already fixed it or you want me to do it?

Oh wait - I grabbed the direct link from above and thought that was the fixed version - was about to try it but am now thinking that it still needs to be fixed, correct?

There was no issue with 7.4.2 build. No can test it if you want. We need to fix ES 7.5.0

can you please fix it?

@cmh I have a problem with upload manually created binaries to S3. But you can download them from here now: https://drive.google.com/drive/folders/1W7dpd90BS8qlWTeoIgizWQmHktFWywdC?usp=sharing

1 Like

7.5.0 from https://readonlyrest.com/download/ should be ok now.

1 Like

Downloaded from this link to confirm as well as the google drive, and the sizes were different.

123-MBP:~/Downloads$ ls -l readon*
[email protected] 1 cheerschap  staff  62086897 Dec 19 11:54 readonlyrest-1.18.9_es7.5.0(1).zip
[email protected] 1 cheerschap  staff  62108152 Dec 12 19:50 readonlyrest-1.18.9_es7.5.0.zip

I’ve now tried both of them and they both give the Java Runtime error.

The SHA1 of the one from the main download page matched, but still gives the error. Got the SHA1 of the one that is properly fixed?

sorry, my fault. Please download 7.5.0. Should be fine now.

1 Like

Ah yes, great success! 7.5.0 box started up and joined the cluster, and the peasants rejoiced.

Thanks for the help, hopefully I won’t have too much more … oh right there is one other thing but I’ll ask that separately after I spend some time making sure I can’t do it.

Thank you!

1 Like