RoR Enterprise 1.31.0 7.12.1 Tenancy switch, caching issues


RoR Enterprise 1.31.0
Elasticsearch 7.12.1
Kibana 7.12.1

If you tenancy hop with
readonlyrest_kbn.clearSessionOnEvents: [“never”]
in your kibana.yml and you hop from RO to RW rights, you do not get the RW rights, you need to do a hard refresh in chrome.

Dummy example config:

  • name: “Allow master Kibana RO access”
    indices: [".kibana", “.kibana_7.12.1”, “aaa_dummy_index”]
    kibana_access: ro
    kibana_hide_apps: [“Management|Stack Monitoring”, “Analytics|Maps”, “Observability”, “Security”, “readonlyrest_kbn”, “Analytics|Canvas”, “Management|Dev Tools”, “Management”]
    groups: [“kibana_only”]
  • name: “XXX custom kibana”
    indices: [“kibana_XXX”]
    kibana_access: rw
    kibana_index: “kibana_XXX”
    kibana_hide_apps: [“Management|Stack Monitoring”, “Analytics|Maps”, “Observability”, “Security”, “readonlyrest_kbn”, “Analytics|Canvas”, “Management|Dev Tools”, “Management”]
    groups: [“XXX_custom”]


  • username: YYY
    auth_key_sha256: ZZZ
    groups: [“kibana_only”,“XXX_custom”]

If you switch from kibana_only to XXX_custom, the UI still shows a RO interface.
Ctrl+Shift+R (hard reload) reloads the page and then gives correct UI.

readonlyrest_kbn.clearSessionOnEvents: [“never”]
readonlyrest_kbn.clearSessionOnEvents: [“tenancyHop”]
Fixes the issue. But this clears the dev tools, which is not ideal for us.

We were on Kibana 7.6.1 with RoR 1.25.0 before upgrading recently, and there the above work properly.

Interesting bug, will add this to Jira immediately. Thanks @ronald.vanboven we will report back to this thread.

By the way, have you tried this is still the case in the latest ROR 1.32.0? There’s been a lot of changes in this latest iteration.

No, not yet.
We just finished upgrading to 1.31.0.
Due to vacation schedueles testing 1.32.0 might take a while.

OK we will give a try to reproduce this on 1.32.0, we might get lucky (or unlucky?) and reproduce it there too.

Thanks, by the way, dark/light mode in Kibana suffers from the same issue but that has been there for longer, I think.
But this is less important for us.

Can you expand a bit on the issue with dark and ligh mode?

If you have two tenancies, one with Kibana dark mode enabled and one with Kibana dark mode disabled and you switch tenancies between them, the GUI stays as it was in the previous tenancy.

So switch from tenancy with dark mode enabled to a tenancy with dark mode disabled, the dark mode stays enabled in your GUI.
Also here, a Ctrl+Shift+R resolve the issues. This was already happening in 7.6.1 / 1.25.0 (as I known somebody complaint about that to me on that version).

Like I said, less important for us, but maybe also something to look into.

1 Like

OK I think I have addressed both the issues, would you like a build for Kibana 7.12.1?

Yes, just tried the test build. It fixes both issues. Thanks.

1 Like

Great! Thanks for the quick check. These fixes will be available in ROR version > 1.32.0.
This applies new platform code, so Kibana >= 7.9.0.