ROR return incomplete response for request GET */_alias

Hello. We have some trouble with new versions of ROR and ELS.
Request GET */_alias return only indices with aliases.

Wrong behavior
Config:

readonlyrest:
    enable: true
    access_control_rules:
    - name: test1access
      auth_key: test:test
      type: allow

Request:

curl -u test:test -XGET http://127.0.0.1:9200/test_*/_alias

Response:

{“test_5”:{“aliases”:{“test_deflector”:{}}}}

Log:

[2021-06-02T10:45:02,981][INFO ][tech.beshu.ror.accesscontrol.logging.AccessControlLoggingDecorator] [hostname]ALLOWED by { name: ‘test1access’, policy: ALLOW, rules: [auth_key] req={ ID:316431193-724160124#269, TYP:GetAliasesRequest, CGR:N/A, USR:test, BRS:true, KDX:null, ACT:indices:admin/aliases/get, OA:10.1.0.1/32, XFF:null, DA:10.1.0.1/32, IDX:test_,, MET:GET, PTH:/test_/_alias, CNT:<N/A>, HDR:Accept=/, Authorization=, Host=hostname:9200, User-Agent=curl/7.29.0, content-length=0, HIS:[test1access-> RULES:[auth_key->true] RESOLVED:[user=test;indices=test_,*]], }

Expected behavior:
Config:

readonlyrest:
    enable: false

Request:

curl -u test:test -XGET http://127.0.0.1:9200/test_*/_alias

Response:

{“test_4”:{“aliases”:{}},“test_5”:{“aliases”:{“test_deflector”:{}}}}

As you can see, part {“test_4”:{“aliases”:{}} is absent in response, when ror is enabled.

Environment:

/usr/share/elasticsearch/bin/elasticsearch-plugin list -v
Plugins directory: /usr/share/elasticsearch/plugins
readonlyrest
- Plugin information:
  Name: readonlyrest
  Description: Safely expose Elasticsearch REST API
  Version: 1.26.1
  Elasticsearch Version: 7.10.1
  Java Version: 1.8

Note. On the old versions ELS (6.5.4) and ROR (1.16.33) this example works great and return full response.
Graylog getting information about count of indices from this request. As a result rotaion indices mechanism does not work.

thanks for reporting the issue! We’ll fix it soon

1 Like

Hello. Thank you for fast response!
This feature very important for us. Need i create new issue in github or you already create this?

No need to create an issue in github. We’ve already done it in our internal bug tracker. I’ll let you know when it’s fixed.

Ok. Thank you! We’ll wait.