Security settings Readonly


#1

Hi,
why I cannot log in with a new user that I inserted on Kibana Security settings?

  name: '::INCO::'
  kibana_access: ro
  indices: [.kibana, 'sidad-*']
  kibana_hide_apps: [readonlyrest_kbn, timelion, 'kibana:dev_tools', 'kibana:management']
  auth_key: 'intco:ielco.2020'

because I have to restart Elasticsearch to apply the changes
RO Elastic. 1.16.9 (5.5.0 version)
RO kibana. 0.1.6-pre1 (5.5.0 version).


(Simone Scarduzio) #2

How are you adding the new user? Editing elasticsearch.yml? Or from the web UI in Kibana?
If you edit the elasticsearch.yml you have to reboot (and no .readonlyrest index has to be present). If you are using the Kibana admin web UI you just need to press commit button and it should refresh the settings on the spot.