Unsupported http.type [ssl_netty4] with ES 8.12.2 and ROR 1.55

When i add http.type: ssl_netty4 in elasticsearch.yml, i have the error unsupported http.type ssl_netty4.
The line xpack.security.enabled: false is present in the file.
i also set to false xpack.security.http.ssl and xpack.security.transport.ssl

I also tried to add # for all the other xpack lines in eleasticsearch.yml but in that case i have this error : invalid configuration for xpack.security.transport.ssl - [xpack.security.transport.ssl.enabled] is not set, but the following settings have been configured in elasticsearch.yml : [xpack.security.transport.ssl.keystore.secure_password,xpack.security.transport.ssl.truststore.secure_password]

It’s probably an error in my readonlyrest.yml but i don’t find what’s wrong.
I tried with different keystore.jks files (self signed or not) but the error still the same.

Here is the content of my readonlyrest.yml
keystore_file: “keystore.jks”
keystore_pass: readonlyrest
key_pass: readonlyrest


  • name: “Require HTTP Basic Auth”
    type: allow
    auth_key: elastic:mypassword

  • name: Accept requests from cloud1 on my_index
    groups: [“cloud1”]
    indices: [“myindex”]


  • username: elastic
    auth_key: elastic:mypassword
    groups: [“cloud1”]

Can you help my to find what’s wrong ?

Thank’s for your help.

you put the ROR settings without proper formatting so I’m not sure it’s ok.
But based on what I see I created ROR-sandbox based reproducer and I don’t see any problems with it.

Please take a look: ROR SSL configuration example by coutoPL · Pull Request #33 · beshu-tech/ror-sandbox · GitHub

1 Like

In that case it’s probably a problem with the .jks file.
I’ll check that on monday an give you a feedback.
Thank you for your help.

1 Like