Couldn't connect to host error message with ROR 1.17.6_es6.6.0.zip

Hi ,

we have a server with ES 6.6.0 .
when I run curl -XGET against this node on 9200 I get the json output.
running netstat -ntlp | grep 9200 I get :
tcp 0 0 ::xyz:host_ip_address:9200 :::*
then I run elastic-plugin install file:///tmp/readonlyrest-1.17.6_es6.6.0.zip and restart ES service.
checking the elasticsearch/plugins I see the readonlyrest directory .
when I try to search the same curl command again I get error couldn’t connect to host .
I would expect to get the error message configured in the ROR yml file .
even if I add -u username:password to the curl command same error.
if run the above netstat command I see that nothing is listening on 9200 port so I guess that’s the reason .
if I run ps -ef | grep elastic I see the service is up.
when I check the cluster_name.log I see error message :
ERROR [o.e.b.Bottstrap ] [ hostname ] Exception java.lang.IlleagalArgumentException: cannot have more than one plugin implementing a REST wrapper .

can you please guide me what else to check or if I use wrong installation file ?

Thanks .

I’ve just seen that there is a new build 18.1 for ES 6.6.0 .
I’ll try it and update again if the problem is solved or not.

thanks .

ERROR [o.e.b.Bootstrap ] [ hostname ] Exception java.lang.IlleagalArgumentException: cannot have more than one plugin implementing a REST wrapper .

This means that you did not disable xpack security:

Plese see the documentation about this.

thanks a lot Simone, that solved the problem with 17.6 version of ROR .
I’m also going to try 18.1 .

1 Like

Hi Simone , I didn’t know if it’s better to continue this thread or open a dedicated one. if you think that a new one is needed then you I’ll copy it .
the thing is that both 17.6 and 18.1 versions of the ROR plugin are ok . installation succeeds and I’m able to start the ES service .
then I try to install the kibana plugin and I don’t succeed.
I tried both 17.6 and 18.1 .
the command is : /kibana/bin/kibana-plugin install file:///tmp/readonlyrest_kbn_enterprise-1.17.6.zip
I get the output:
Attempting to transfer from file:/// …
Transferring 6630837 bytes …
Transfer complete
Retrieving metadata from plugin archive
Extracting plugin archive
Extraction complete
Optimizing and caching browser bundles …

then it freezes and I am not getting the prompt back .
after 15 - 20 minutes I press ctrl+c to terminate the installation .

Can you please assist ?

sorry , I’ve just seen this post :


and followed the instructions .
version 17.6 is now working .
please ignore the message above .
thanks .

1 Like