Error on kbn module install


(mdnuts) #1

When trying to evaluate the enterprise Kibana plugin I get the error (post optimize).

FATAL Error: Cannot find module ‘./server/routes/lib/connectors/connectorsService’


(Simone Scarduzio) #2

Hi @mdnuts, what build is this? (The whole zip file name you installed)


(mdnuts) #3

readonlyrest_kbn_enterprise-1.17.5-pre1-20190415_es6.7.0


(Simone Scarduzio) #4

Take the non “pre”, which is now out.

https://readonlyrest-data.s3-eu-west-1.amazonaws.com/build/1.17.5/trial/20190418/enterprise/readonlyrest_kbn_enterprise-1.17.5-20190418_es6.7.0.zip?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAJEKIPNTOTIVGQ4EQ/20190419/eu-west-1/s3/aws4_request&X-Amz-Date=20190419T195655Z&X-Amz-Expires=604800&X-Amz-SignedHeaders=host&X-Amz-Signature=88bc46d3c4e42806641d6918e8beb468c6f5c1e2247baa1e2601da23b7eef08c


(mdnuts) #5

ok thank you - got it, trying.


(mdnuts) #6

same error as before.


(mdnuts) #7

not sure if it helps or not, but i navigated and the file (./server/routes/lib/connectors/connectorsService.js) does exist - filesize of 1.1K - permissions the same as sideServer.js (600) and owner/group of kibana.


(Simone Scarduzio) #8

So weird: I downloaded it myself and manually tried the installation, and the functionality before sending the link.

Might help deleting the whole Kibana package from the system and start over?


(mdnuts) #9

I can give it a try on Monday


(mdnuts) #10

removed Kibana, removed all previous files for kibana, installed again, tried plugin installed (no other plugins installed) and received the same error,

Normally with plugin installs i install as user root then chown them like i tried here. This time I also tried sudo as user kibana and attempted the install to the same result.

the full error is:
(after optimizing and caching browser bundles…)

plugin installation was unsuccessful due to error “Command failed: /usr/share/kibana/node/bin/node /usr/share/kibana/src/cli --env.name=production --optimize.useBundleCache=false --server.autoListen=false --plugins.initialize=false”

FATAL Error: Cannot find module ‘./server/routes/lib/connectors/connectorsService’

"


(mdnuts) #11

I was playing around with it this morning, in index.js changing “connectorsService” to “ConnectorsService” (to match filename) let the plugin be installed and optimized.

but then kibana when loading says Error: custom client factory is already set, unable to replace the current one at ScopedSavedObjectsClientProvider.setClientFactory.

after adding the following to kibana.yml

xpack.graph.enabled: false
xpack.ml.enabled: false
xpack.monitoring.enabled: true
xpack.security.enabled: false # this is fundamental!
xpack.watcher.enabled: false

now Kibana tries to load but says
"JSON.parse: unexpected character at line 1 column 1 of the JSON data"
and goes into a continuous loop.


(Simone Scarduzio) #12

Thanks, will look into why this happens and try to resolve the ambiguity at code level to be sure.

Do you have any stack trace? Does it happen as soon as you start Kibana or only when you try to login as a user?
What are your settings?


(mdnuts) #13

that was when i tried to get to the browser to load. kibana itself will appear to load okay on command line output.

you lost me on stack trace.

in my kibana.yml i had
server host: “mysever fqdn”
elasticsearch.hosts: [https://localhost:9200"]
elasticsearch.username: “ausername”
elasticsearch.password: “ausername”
server.ssl.enabled: false
elasticsearch.ssl.verificationMode: none
and the xpack listed above.


(Simone Scarduzio) #14

Yeah generally when errors are thrown you can see a bunch of other lines that trace the developers back to what line of code caused the error.

So the question was: do you have anything more in the logs about that JSON.parse error? Also, maybe have a look if there is something more in elasticsearch.log or in browser’s javascript console.


(mdnuts) #15

i can try to install the plugin again. i wasn’t sure if a regular linux zip of a file was sufficient to install the plugin again or if it needed something special to do it after i played around in that index.js file.


(Simone Scarduzio) #16

I don’t think you have to reinstall, just reproduce the error (i.e. try to reconnect with browser and see if there is more info to be gathered)


(Simone Scarduzio) #17

BTW, would it be better if I gave you a docker compose?


(mdnuts) #18

haven’t had any experience with docker.
loaded the plugin again, the browser console says:

^ a single error about an inline script not firing due to content security policy is expected!
syntaxError: JSON.parse unexpected character at line 1 column 1 of the JSON data
sending check...
navigated to http://myfqdn:5601/app/kibana#?home
navigated to http://myfqdn:5601/app/kibana#?home
unhandled promise rejection: syntaxError: JSON.parse unexpected character at line 1 column 1 of the JSON data
failed to load API 'es_6_0': undefined
failed valid cookie check, redirecting to login
navigated to http://myfqdn:5601/login
navigated to http://myfqdn:5601/

and loops.


(mdnuts) #19

i’m not getting any error messages anywhere else. nothing in ES logs - just shows adding kibana template. kibana logs just show the page being loaded with iana codes of 200, 302 and 304 - nothing unexpected.

in readonlyrest.yml i’ve got

  • first the logstash that is in the docs which works good
  • then kibana’s listing here

then the basic “require HTTP basic Auth” one at the end.


(Joe Bowman) #20

Hi, I’m also seeing the same module error with fresh installs using readonlyrest_kbn_enterprise-1.17.5_es6.7.1.zip and kibana-oss-6.7.1